Hin und wieder lässt man das “Find updates”-Feature im Eclipse laufen, um zu sehen, was es neues gibt.

Im Falle des Subversive-Plugins (Standard-plugin für Subversion) gab es bei der Installation des Updates allerdings Probleme. Man konnte anschließend keine Connectoren für SVN installieren.

[code]
Cannot complete the install because one or more required items could not be found. Software being installed: Subversive SVN Connectors 2.2.2.I20101203-1700 (org.polarion.eclipse.team.svn.connector.feature.group 2.2.2.I20101203-1700) Missing requirement: Subversive SVN Connectors 2.2.2.I20101203-1700 (org.polarion.eclipse.team.svn.connector.feature.group 2.2.2.I20101203-1700) requires ‘org.eclipse.team.svn.feature.group [0.7.9.I20101001-1700,1.0.0)’ but it could not be found

Hier stimmt also etwas mit den Abhängigkeiten nicht bzw. können diese nicht richtig installiert werden. Das ist ein bekanntes Problem, welches durch die Verwendung der “Early Access” Update Site von Subversive behoben werden kann.

http://download.eclipse.org/technology/subversive/0.7/update-site/

Eine genauere Erläuterung wieso es nicht funktioniert, kann hier eingesehen werden (http://www.eclipse.org/subversive/downloads.php#faq):

I could not install connectors after installing plug-in from the Helios repository. What should I do?

There was an issue with update sites layout for “release” versions, meaning that a different releases had references to the same connectors update site location. So, we have decided to correct this issue, so that there will be no problems with the future releases. Unfortunately there is no way to fix the Helios repository at this stage and the right way to avoid the issue is to install the latest plug-in version from the “Early access” update site. It is not the realease but development build, but it still stable and better because it contains a lot of fixes for a different issues.