(Note: This is a news article about the new PocketQuery version for Confluence 3.5.0. If you’re searching for the documentation, you can find it here).

Version 3.5.0 of our plugin PocketQuery for Confluence is now available at the marketplace! It offers the possibility to connect to databases via JNDI and includes a new Velocity API call for more flexible templating and query combination.

What are the main features?

Connect to SQL databases via JNDI

Using connection pooling via JNDI was a feature request we got frequently. We heard you! From now on you can configure a PocketQuery datasource to use an existing JNDI connection. No need to set connection data at multiple places anymore!

More information can be found in this section of the documentation: JNDI Datasources.

More flexible query combination with $PocketQuery.executeQuery()

For more complex scenarios, it is often necessary to combine two queries, e.g. if one query depends on the result of another. Typically, you would then use the Velocity API function $PocketQuery.renderPocketQueryMacro(“mySecondQuery”) within the template of your first query. But simply including the rendered result can be quite limiting, so we introduced $PocketQuery.executeQuery(). This call will simply return the raw result set of the query - if a converter is set, it will be executed, but all rendering will be skipped. Then you can use this result set to extract the information you need and postprocess it in any way you like.

More information can be found in this section of the documentation: The PocketQuery Velocity Helper.

Which minor improvements were made?

Beside the big changes, we also worked on a lot of details and a number of small bugs. For example:

  • Templates with deprecated code remain editable
  • List element sorting stays consistent when changing tabs
  • Enhancing the wording of some info messages

Where to go?